Skip to main content
VulnerabilityPublished

OpenClaw: Native command authorization could skip owner-command enforcement

Affects openclawSource GCVE Database

0

CVSS 7.2 High : upgrade to 2026.5.6 soon.

Data as of 2 Jul 2026, 23:18 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N

What to do

Upgrade openclaw to 2026.5.6.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.6
Fixed in
  • 2026.5.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenClaw version 2026.5.6. Until systems are updated, it is advised to restrict native command surfaces to trusted senders only. Operators should maintain narrow channel and tool allowlists, avoid sharing a Gateway among mutually untrusted users, and disable the affected feature if it is not required. These mitigations reduce the risk of unauthorized command execution until the official patch is applied.

Description

OpenClaw contains a vulnerability in its native command authorization that may bypass owner-command enforcement. This allows a sender able to trigger native command handling to authorize commands that should be restricted to owners only. The vulnerability affects versions prior to 2026.5.6. The impact depends on the operator's configuration and whether untrusted input can reach the vulnerable code path. A fix is available in version 2026.5.6. Until patched, it is recommended to restrict native command access to trusted senders and limit channel and tool allowlists.

References

Community reviews

Loading reviews…