OpenClaw: Non-owner chat senders could issue device-pairing bootstrap codes
Affects openclawSource GCVE Database
CVSS 8.3 High : upgrade to 2026.5.4 soon.
Data as of 2 Jul 2026, 23:20 UTC
- Patch
- Available – fixed in 2026.5.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:LWhat to do
Upgrade openclaw to 2026.5.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OpenClaw to version 2026.5.4 or later, where this vulnerability is patched. Additionally, review all paired devices and remove any unexpected or unauthorized entries. Limit chat command access in shared channels to only those users who should be authorized to manage device pairing to reduce risk.
Description
OpenClaw versions prior to 2026.5.4 contain a vulnerability in the bundled device-pair plugin that allows authorized non-owner chat senders to issue device-pairing bootstrap codes. This enables these users to enroll devices with operator/node capabilities, which retain persistent credentials until removed. The vulnerability requires the attacker to have chat command access and does not affect unauthenticated users. The issue is fixed in version 2026.5.4.