Skip to main content
VulnerabilityPublished Updated

CVE-2026-53836: OpenClaw · PowerShell encoded-command aliases could miss exec allowlist checks

Affects openclawSource GCVE Database

0

Mentioned vulnerabilities

CVSS 8.8 High : upgrade to 2026.5.12 soon.

Data as of 26 Oct 2026, 15:56 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.12
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade openclaw to 2026.5.12.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.12
Fixed in
  • 2026.5.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenClaw version 2026.5.12. Until systems are updated, avoid allowlisting PowerShell wrapper forms and require explicit approval for encoded commands. Additionally, keep channel and tool allowlists narrow, avoid sharing a Gateway instance between mutually untrusted users, and disable the affected feature if it is not required.

Description

OpenClaw versions prior to 2026.5.12 have a vulnerability where PowerShell encoded-command aliases may bypass execution allowlist checks. This occurs because abbreviated encoded-command flags can use alias forms not recognized by the allowlist parser. The vulnerability affects configurations where this feature is enabled and reachable, potentially allowing execution of encoded PowerShell content without proper allowlist validation. The issue does not alter OpenClaw's trusted-operator model and depends on operator configuration and input trust levels. A fix is available in version 2026.5.12. Until patched, it is recommended to avoid allowlisting PowerShell wrapper forms and require approval for encoded commands. Additional hardening includes narrowing allowlists, isolating Gateway users, and disabling the affected feature if not needed.

References

Community reviews

Loading reviews…