Skip to main content
VulnerabilityPublished

OpenClaw: QQBot admin commands could skip DM-only and allowFrom policy

Affects openclawSource GCVE Database

0

CVSS 9.3 Critical : upgrade to 2026.4.29 as a priority.

Data as of 2 Jul 2026, 23:20 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.4.29
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade openclaw to 2026.4.29.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.4.29
Fixed in
  • 2026.4.29

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenClaw version 2026.4.29. Until systems are updated, it is recommended to disable exported QQBot admin commands or restrict QQBot access to trusted users only. Additionally, operators should keep channel and tool allowlists narrow, avoid sharing a Gateway between mutually untrusted users, and disable the affected feature when not needed.

Description

A vulnerability in OpenClaw's QQBot admin commands allows bypassing DM-only and allowFrom policy checks. This means that admin commands intended to be restricted to direct messages or specific senders can be triggered from unauthorized contexts. The issue affects versions prior to 2026.4.29. The vulnerability does not alter the overall trusted-operator model of OpenClaw but can lead to unauthorized execution of admin commands depending on configuration. The first stable patched version is 2026.4.29. Mitigations include disabling the affected QQBot admin commands or restricting QQBot access until the patch is applied.

References

Community reviews

Loading reviews…