Skip to main content
VulnerabilityPublished

OpenClaw: Scoped chat.send route inheritance could bypass admin command scope gates

Affects openclawSource GCVE Database

0

CVSS 8.8 High : upgrade to 2026.5.18 soon.

Data as of 2 Jul 2026, 23:21 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.18
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade openclaw to 2026.5.18.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.18
Fixed in
  • 2026.5.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to OpenClaw version 2026.5.18 or later, where this vulnerability is patched. Until the upgrade is applied, do not grant operator.write tokens to clients capable of delivering commands into sessions with external routes unless those clients are fully trusted with admin-level command effects.

Description

A vulnerability in OpenClaw's scoped Gateway chat.send route allows commands requiring higher privileges (operator.approvals or operator.admin) to be executed with only operator.write scope when routed through inherited external delivery routes. This affects deployments where scoped Gateway clients with operator.write can deliver commands into sessions with external routes. The issue is fixed in version 2026.5.18. Until upgraded, avoid granting operator.write tokens to clients that can deliver commands into sessions with external routes unless fully trusted.

References

Community reviews

Loading reviews…