Skip to main content
VulnerabilityPublished

OpenClaw: Shell wrapper argv could change between approval and execution

Affects OpenclawSource GCVE Database

0

CVSS 8.7 High : upgrade to 2026.5.18 soon.

Data as of 2 Jul 2026, 23:22 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.18
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

What to do

Upgrade Openclaw to 2026.5.18.

Affected software

ProductAffectedFixed in
npmOpenclawAffected
  • <2026.5.18
Fixed in
  • 2026.5.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OpenClaw version 2026.5.18. Until patched, operators should require explicit approval for shell wrappers and avoid durable allowlists for commands that heavily use wrappers. Additional mitigations include keeping channel and tool allowlists narrow, avoiding sharing one Gateway between mutually untrusted users, and disabling the affected shell wrapper feature when not needed.

Description

OpenClaw versions prior to 2026.5.18 contain a vulnerability where the shell wrapper argument vector (argv) can change between approval and execution. This discrepancy allows a command shape to be executed that was not originally checked against the allowlist, potentially bypassing intended command restrictions. The vulnerability affects the shell wrapper feature and depends on operator configuration and input trust boundaries. The issue does not alter OpenClaw's trusted-operator model but requires careful policy and approval management. A fix is available starting with version 2026.5.18.

References

Community reviews

Loading reviews…