Skip to main content
VulnerabilityPublished

OpenClaw: Trusted-proxy Control UI WebSocket accepted client-declared scopes before pairing

Affects openclawSource GCVE Database

0

CVSS 8.8 High : upgrade to 2026.5.18 soon.

Data as of 2 Jul 2026, 23:20 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.18
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade openclaw to 2026.5.18.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.18
Fixed in
  • 2026.5.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenClaw to version 2026.5.18 or later, where this vulnerability is patched. Until the upgrade is applied, restrict trusted-proxy Control UI access to only those users who are authorized for the scopes they request. Additionally, restart the gateway after any changes to trusted-proxy authorization policies to ensure proper enforcement.

Description

OpenClaw's trusted-proxy Control UI mode improperly accepted client-declared operator scopes on WebSocket connections before these scopes were validated and bound to a server-approved pairing or authorization baseline. This vulnerability affects deployments using the trusted-proxy authentication mode, allowing a restricted or unpaired trusted-proxy client to gain elevated operator.admin authority on a live WebSocket connection. The issue is resolved in OpenClaw version 2026.5.18 and later.

References

Community reviews

Loading reviews…