Skip to main content
VulnerabilityPublished

CVE-2026-62194: OpenClaw versions before 2026.6.9 contain a privilege escalation vulnerability in the plugin install

Affects openclawSource GCVE Database

0
Compare

Not known to be exploited · CVSS 8.8 High : upgrade to 2026.6.9 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2026.6.9
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openclaw/openclaw to 2026.6.9.

Affected software

ProductAffectedFixed in
GitHubopenclaw/openclawpkg:github/openclaw/openclawOther threatsAffected
  • <2026.6.9
Fixed in
  • 2026.6.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, restrict access to plugin installation features and review configurations to ensure input paths and features are not misconfigured or exposed to lower-trust users.

Description

OpenClaw versions before 2026.6.9 contain a privilege escalation vulnerability in the plugin install commands. This flaw allows lower-trust callers to execute or persist actions beyond their intended authorization by exploiting misconfigured input paths or enabled features. The vulnerability enables attackers to escalate privileges and perform unauthorized actions when the vulnerable feature is reachable.

References

Community reviews

Loading reviews…