Skip to main content
VulnerabilityPublished Updated

CVE-2026-41336: OpenClaw · Workspace `.env` can override the bundled hooks root and load attacker hook code

Affects openclawSource GCVE Database

0

Not known to be exploited · CVSS 7.8 High : upgrade to 2026.3.31 soon.

Data as of 27 Oct 2026, 02:25 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.3.31
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade openclaw to 2026.3.31.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.3.31
Fixed in
  • 2026.3.31

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenClaw to version 2026.3.31 or later, where the vulnerability is fixed. Versions prior to 2026.3.31 are vulnerable. No other mitigations are indicated in the advisory.

Description

OpenClaw versions up to 2026.3.28 allow a workspace .env file to override the bundled hooks root directory, enabling loading of attacker-controlled hook code. This vulnerability is fixed in version 2026.3.31. The flaw can lead to high impact including confidentiality, integrity, and availability compromise.

References

Community reviews

Loading reviews…