CVE-2026-53819: OpenClaw · Workspace .env could override Homebrew executable selection for skill install flows
Affects openclaw-cliSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2026.5.28 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2026.5.27, 2026.5.28
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade openclaw-cli to 2026.5.28; openclaw to 2026.5.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Homebrewopenclaw-clipkg:brew/openclaw-cliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in openclaw-cli version 2026.5.27. Users should upgrade to this version or later. Until patched, avoid running skill install flows from untrusted workspaces. Additionally, narrow channel and tool allowlists, avoid sharing Gateways between mutually untrusted users, and disable the affected feature when not needed.
Description
A vulnerability in openclaw-cli allows a workspace .env file to override the Homebrew executable selection during skill install flows. This could cause an unintended Homebrew-compatible executable to run if the feature is enabled and reachable. The issue affects versions prior to 2026.5.27. The vulnerability relies on trusted operators opening repositories with a crafted .env file. The impact depends on the operator's configuration and the trust level of inputs reaching the affected path. A patch is available in version 2026.5.27. Until patched, it is recommended to avoid running skill install flows from untrusted workspaces and to apply configuration hardening measures.
References
- github.com/openclaw/openclaw/security/advisories/GHSA-8wg3-5mcm-fjq8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-53819 (opens in a new tab)
- github.com/openclaw/openclaw (opens in a new tab)
- vulncheck.com/advisories/openclaw-arbitrary-homebrew-executable-execution-via-workspace-env-override (opens in a new tab)