Skip to main content
Report · SecurityWeekAbout CVE-2026-123158Published

OpenSSH Rushes Patches for ‘SSHole’ Authentication Bypass

Source SecurityWeek

0
Compare
Authoritative record:CVE-2026-123158· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 10.6p2 soon.

Data as of 6 Nov 2026, 12:18 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 10.6p2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade OpenSSH to 10.6p2.

Affected software

ProductAffectedFixed in
OpenBSDOpenSSHAffected
  • <10.6p2
Fixed in
  • 10.6p2

AI-suggested

Apply the OpenSSH 10.6p2 patch immediately and restart the sshd service to replace the running daemon. If patching is not immediately possible, disable password authentication in sshd configuration and restart sshd. Alpine Linux specifically recommends these actions and warns that the attack requires an account with a '*' password field and at least one account with a SHA-256 or SHA-512 hashed password. Monitoring for updates from OpenSSH and Linux distribution vendors is advised.

Description

A high-severity authentication bypass vulnerability (CVE-2026-123158) affects OpenSSH servers on Linux distributions using musl libc without PAM enabled. The flaw allows attackers to log in to certain accounts by supplying any password between 257 and 1024 characters. This impacts accounts with a password field set to "*" (no password) and requires the presence of at least one local account with a SHA-256 or SHA-512 hashed password. The vulnerability is present in Alpine Linux releases 3.16 through 3.24 and edge, among others. OpenSSH 10.6p2 includes patches to fix this issue. Immediate patching or disabling password authentication is recommended to mitigate risk.

References

Community reviews

Loading reviews…