Skip to main content
CVE-2026-123158VulnerabilityPublished

OpenSSH · Sshd

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123158· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 10.6p2 soon.

Data as of 5 Nov 2026, 19:47 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.18.1
Patch
Available – fixed in 10.6p2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade OpenSSH to 10.6p2.

Affected software

ProductAffectedFixed in
OpenBSDOpenSSHAffected
  • <10.6p2
Fixed in
  • 10.6p2

AI-suggested

A fix is available in OpenSSH version 10.6p2 and later. Users should upgrade to version 10.6p2 or newer to remediate this vulnerability. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes.

Description

OpenSSH versions before 10.6p2 on Linux systems using musl libc without PAM are vulnerable to a password authentication bypass. This flaw arises from a misinterpretation of whether a string is a password hash, allowing passwords between 256 and 1024 characters to succeed improperly. Alpine Linux is an example of a platform affected by this issue.

References

Community reviews

Loading reviews…