Skip to main content
VulnerabilityPublished

CVE-2026-54875: openssl security update

Affects opensslSource GCVE Database

0
Compare

Not known to be exploited · CVSS 3.7 Low : upgrade to 3.0.12-55.oe2403sp1 when convenient.

Data as of 29 Oct 2026, 10:47 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.12-55.oe2403sp1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openssl to 3.0.12-55.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1opensslpkg:rpm/openEuler/openssl&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <3.0.12-55.oe2403sp1
Fixed in
  • 3.0.12-55.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Fixed versions of OpenSSL have been released: upgrade to OpenSSL 4.0.3 if using 4.0, 3.6.5 if using 3.6, 3.5.9 if using 3.5, or 3.4.8 if using 3.4. Versions 3.0, 1.1.1, and 1.0.2 are not affected and do not require action. Applying these updates will mitigate the timing and cache side-channel vulnerability. No additional mitigations are specified or required.

Description

A timing and cache side-channel vulnerability exists in OpenSSL's SM2 private key operations on ARM64 and RISC-V platforms due to a non-constant-time scalar multiplication implementation. This flaw allows attackers who can measure execution time or observe cache access patterns during SM2 signing or decryption to potentially learn secret scalar information. The issue affects OpenSSL versions 4.0, 3.6, 3.5, and 3.4 on these platforms. Versions 3.0, 1.1.1, and 1.0.2 are not affected. Fixed versions have been released to address this vulnerability.

References

Community reviews

Loading reviews…