Skip to main content
VulnerabilityPublished

CVE-2026-54875: openssl security update

Affects opensslSource GCVE Database

0
Compare

Not known to be exploited · CVSS 3.7 Low : upgrade to 3.0.12-55.oe2403sp3 when convenient.

Data as of 29 Oct 2026, 10:47 UTC

CVSS 3.1 base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.0.12-55.oe2403sp3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade openssl to 3.0.12-55.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3opensslpkg:rpm/openEuler/openssl&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <3.0.12-55.oe2403sp3
Fixed in
  • 3.0.12-55.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users of OpenSSL 4.0, 3.6, 3.5, and 3.4 on ARM64 and RISC-V platforms should upgrade to OpenSSL 4.0.3, 3.6.5, 3.5.9, or 3.4.8 respectively, where this vulnerability is fixed. Versions 3.0, 1.1.1, and 1.0.2 are not affected and require no action. No additional mitigations are specified by the vendor.

Description

A timing and cache side-channel vulnerability exists in OpenSSL's SM2 private key operations on ARM64 and RISC-V platforms due to a non-constant-time scalar multiplication implementation. This flaw allows an attacker who can measure timing or cache access patterns during SM2 signing or decryption to potentially learn information about the secret scalar. The issue affects OpenSSL versions 4.0, 3.6, 3.5, and 3.4 on these architectures. Versions 3.0, 1.1.1, and 1.0.2 are not affected. Fixes are available in OpenSSL 4.0.3, 3.6.5, 3.5.9, and 3.4.8.

References

Community reviews

Loading reviews…