CVE-2026-116694: OpenTelemetry Python · Unbounded memory allocation in Jaeger baggage propagation
Affects opentelemetry-propagator-jaegerSource GCVE Database
Not known to be exploited · CVSS 6.3 Medium : upgrade to 1.45.0 when convenient.
Data as of 27 Oct 2026, 22:27 UTC
- Patch
- Available – fixed in 1.45.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade opentelemetry-propagator-jaeger to 1.45.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIopentelemetry-propagator-jaeger | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade opentelemetry-propagator-jaeger to version 1.45.0 or later, which enforces limits on baggage extraction to prevent unbounded memory allocation. If upgrading is not immediately possible, ensure that transport-level limits on header size and number are properly configured and enforced to mitigate risk. No other specific actions are required as the vulnerability does not expose or modify telemetry data.
Description
A vulnerability in the OpenTelemetry Python Jaeger propagator (opentelemetry-propagator-jaeger) prior to version 1.45.0 allows unbounded memory allocation when processing inbound 'uberctx-*' baggage headers. This can lead to increased CPU and memory usage per request, potentially causing denial-of-service conditions. The issue affects deployments that enable the Jaeger propagator and accept untrusted inbound propagation headers, especially where transport-level limits are absent or set higher than baggage limits. The vulnerability does not expose or modify telemetry data nor allow code execution. It is mitigated by upgrading to version 1.45.0 or later, which enforces limits on baggage extraction.
References
- github.com/open-telemetry/opentelemetry-python/security/advisories/GHSA-f5m9-jfrj-jjj7 (opens in a new tab)
- github.com/open-telemetry/opentelemetry-python/pull/5556 (opens in a new tab)
- github.com/open-telemetry/opentelemetry-python/commit/65c4eeb87cd3815dc795d3b5485e9ea0d5affcc7 (opens in a new tab)
- github.com/open-telemetry/opentelemetry-python (opens in a new tab)
- github.com/open-telemetry/opentelemetry-python/releases/tag/v1.45.0 (opens in a new tab)