CVE-2026-109932: undici WebSocket client vulnerable to Denial of Service via unbounded automatic PONG buffering
Affects undiciSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 6.29.1 when convenient.
Data as of 27 Oct 2026, 20:30 UTC
- Patch
- Available – fixed in 6.29.1, 7.30.1, 8.12.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade undici to 6.29.1; undici to 7.30.1; undici to 8.12.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmundici | Affected
| Fixed in
|
| npmundici | Affected
| Fixed in
|
| npmundici | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available by upgrading to undici versions 6.29.1, 7.30.1, or 8.12.2. These versions handle socket backpressure correctly by pausing WebSocket frame parsing when the automatic PONG response queue is full and resuming on drain, preventing unbounded memory growth. No workarounds are available.
Description
undici's WebSocket client, including Node.js's bundled globalThis.WebSocket, is vulnerable to a denial of service condition caused by unbounded automatic PONG buffering. A malicious WebSocket server can send continuous PING frames causing the client to queue PONG responses without respecting backpressure, leading to memory exhaustion and process termination. This affects undici versions from 5.15.0 up to but not including 6.29.1, 7.0.0 up to 7.30.1, and 8.0.0 up to 8.12.2. Upgrading to versions 6.29.1, 7.30.1, or 8.12.2 mitigates the issue by properly handling backpressure.
References
- github.com/nodejs/undici/security/advisories/GHSA-9fm3-97px-rjf6 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-109932 (opens in a new tab)
- github.com/nodejs/undici/commit/39f93e142df03e559fe7c3d1fc7fba9beee2c185 (opens in a new tab)
- github.com/nodejs/undici/commit/53944624462b6797560288c55dbd8c66857bb495 (opens in a new tab)
- github.com/nodejs/undici/commit/b217373bb024cd93f85eb5b3ffd25684855f60f8 (opens in a new tab)
- cna.openjsf.org/security-advisories.html (opens in a new tab)
- github.com/nodejs/undici (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v6.29.1 (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v7.30.1 (opens in a new tab)
- github.com/nodejs/undici/releases/tag/v8.12.2 (opens in a new tab)