Skip to main content
CVE-2026-119409VulnerabilityPublished

OPNsense before 26.7.8 contains a command injection vulnerability that allows authenticated users with the System: Firmware privilege to execute commands as root by storing a malicious firmware mirror URL

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119409· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 26.7.8 soon.

Data as of 30 Oct 2026, 13:35 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.6
CNA (VulnCheck)CVSS 3.17.2
Patch
Available – fixed in 26.7.8
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade core and opnsense/core to 26.7.8.

Affected software

ProductAffectedFixed in
opnsensecoreAffected
  • <26.7.8
Fixed in
  • 26.7.8
GitHubopnsense/corepkg:github/opnsense/coreOther threatsAffected
  • <26.7.8
Fixed in
  • 26.7.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

OPNsense before 26.7.8 contains a command injection vulnerability that allows authenticated users with the System: Firmware privilege to execute commands as root by storing a malicious firmware mirror URL. Attackers can submit shell metacharacters through POST /api/core/firmware/set that opnsense-update evaluates with eval, and can also disable package signature verification through sed injection.

References

Community reviews

Loading reviews…