Skip to main content
CVE-2026-122007VulnerabilityPublished

Oqtane Framework before 10.3.0 contains a broken access control vulnerability in SettingController.cs that allows an

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122007· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 10.3.0 soon.

Data as of 4 Nov 2026, 16:33 UTC

CVSS 4.0 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.4
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 10.3.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade oqtane.framework to 10.3.0.

Affected software

ProductAffectedFixed in
oqtaneoqtane.frameworkAffected
  • >=1.0.0 <10.3.0
Fixed in
  • 10.3.0
GitHuboqtane.frameworkpkg:github/oqtane.frameworkOther threatsAffected
  • >=1.0.0 <10.3.0
Fixed in
  • 10.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since the vulnerability affects versions before 10.3.0, upgrading to version 10.3.0 or later is implied to remediate the issue. If you cannot patch yet, restrict site administrator privileges carefully and monitor access to sensitive settings.

Description

Oqtane Framework versions prior to 10.3.0 have a broken access control vulnerability in SettingController.cs. This flaw allows an authenticated site administrator to read and modify settings of other sites within the same tenant database by supplying arbitrary entity IDs for Site or Role settings. The vulnerability arises because authorization checks do not verify that the requested site matches the current alias SiteId. Exploitation can disclose sensitive configuration values such as SMTPPassword, SMTPClientSecret, and ExternalLogin ClientSecret, and can alter another site's OIDC/OAuth2 authentication settings without requiring host-level privileges.

References

Community reviews

Loading reviews…