Skip to main content
CVE-2026-49434VulnerabilityPublished Updated

Org.apache.activemq:activemq broker: Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All have an Improper

Affects org.apache.activemq:activemq-brokerSource GCVE Database

0
Compare
Authoritative record:CVE-2026-49434· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.19.8 soon.

Data as of 4 Nov 2026, 16:28 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.activemq:activemq-broker and org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all to 5.19.8; org.apache.activemq:activemq-broker and org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:activemq-brokerAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-brokerAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-allAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Input Validation vulnerability in Apache ActiveMQ Broker, Apache ActiveMQ, Apache ActiveMQ All. An attacker that has access to publish or modify entries in LDAP that match the configured searchBase and searchFilter can instantiate denied transports inside the broker JVM. This can be used to fetch an attacker URL and spawn a second BrokerService inside the same JVM. This issue affects Apache ActiveMQ Broker: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7. Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

References

Community reviews

Loading reviews…