CVE-2024-43115: Org.apache.dolphinscheduler:dolphinscheduler: Apache DolphinScheduler vulnerable to Alert Script Attack
Affects org.apache.dolphinscheduler:dolphinschedulerSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 3.2.2 soon.
Data as of 4 Nov 2026, 17:16 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 8.8 |
|---|
- Patch
- Available – fixed in 3.2.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 3 Sep 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.2.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.dolphinscheduler:dolphinscheduler | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Improper Input Validation vulnerability in Apache DolphinScheduler. An authenticated user can execute any shell script server by alert script. This issue affects Apache DolphinScheduler: before 3.2.2. Users are recommended to upgrade to version 3.3.1, which fixes the issue.