Org.apache.dolphinscheduler:dolphinscheduler: Apache DolphinScheduler has an Incorrect Authorization Vulnerability
Affects org.apache.dolphinscheduler:dolphinschedulerSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 3.4.1 soon.
Data as of 27 Oct 2026, 01:29 UTC
- Patch
- Available – fixed in 3.4.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 24 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.dolphinscheduler:dolphinscheduler | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache DolphinScheduler to version 3.4.1 or later, where this vulnerability is fixed. Since a patch is available and the issue is resolved in the fixed version, upgrading is the recommended remediation.
Description
Apache DolphinScheduler versions prior to 3.4.1 contain an incorrect authorization vulnerability that allows authenticated users with system login permissions to use tenants not defined on the platform during workflow execution. This issue is fixed in version 3.4.1.