Skip to main content
CVE-2026-49432VulnerabilityPublished Updated

Org.apache.activemq:apache activemq: Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper Input

Affects org.apache.activemq:apache-activemqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-49432· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 5.19.8 soon.

Data as of 5 Nov 2026, 18:50 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-stomp to 5.19.8; org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-stomp to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-allAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-stompAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-stompAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ to version 5.19.8 or 6.2.7, where this vulnerability is fixed. Since a patch is available and officially released, applying these updates is the recommended mitigation.

Description

Apache ActiveMQ versions before 5.19.8 and from 6.0.0 before 6.2.7 contain an improper input validation vulnerability in the STOMP connector. A remote unauthenticated attacker can exploit this by sending a negative content-length, causing denial-of-service conditions. The attack can lead to out-of-memory conditions or abnormal connection closures depending on the STOMP transport type. Upgrading to versions 5.19.8 or 6.2.7 resolves this issue.

References

Community reviews

Loading reviews…