Skip to main content
CVE-2026-40466VulnerabilityPublished Updated

Org.apache.activemq:apache activemq: Apache ActiveMQ Vulnerable to Improper Input Validation and Code Injection

Affects org.apache.activemq:apache-activemqSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2026-40466· High 8.8

Not known to be exploited · public detection template (Nuclei) · CVSS 8.8 High : upgrade to 5.19.6 soon.

Data as of 27 Oct 2026, 01:29 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.19.6, 6.2.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-broker to 5.19.6; org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-broker to 6.2.5.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:activemq-allAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:activemq-brokerAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Mavenorg.apache.activemq:activemq-brokerAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ to version 5.19.6 or 6.2.5, where this vulnerability is fixed. Since a patch is available and official fixes exist, applying these updates is the recommended remediation. No alternative mitigations are specified.

Description

Apache ActiveMQ contains an improper input validation and code injection vulnerability that allows an authenticated attacker to bypass previous fixes by adding a connector using an HTTP Discovery transport via Jolokia if the activemq-http module is present. This can lead to arbitrary code execution on the broker's JVM through Spring XML application context loading before configuration validation. The issue affects versions before 5.19.6 and from 6.0.0 before 6.2.5. Upgrading to versions 5.19.6 or 6.2.5 mitigates the vulnerability.

References

Community reviews

Loading reviews…