Skip to main content
CVE-2026-52760VulnerabilityPublished Updated

Org.apache.activemq:apache activemq: Apache ActiveMQ, Apache ActiveMQ Web Console vulnerable to Cross-site Scripting

Affects org.apache.activemq:apache-activemqSource GCVE Database

0
Compare
Authoritative record:CVE-2026-52760· Medium 6.1

Not known to be exploited · CVSS 6.1 Medium : upgrade to 5.19.8 when convenient.

Data as of 5 Nov 2026, 18:50 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.19.8, 6.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade org.apache.activemq:apache-activemq and org.apache.activemq:activemq-web-console to 5.19.8; org.apache.activemq:apache-activemq and org.apache.activemq:activemq-web-console to 6.2.7.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7
Mavenorg.apache.activemq:activemq-web-consoleAffected
  • <5.19.8
Fixed in
  • 5.19.8
Mavenorg.apache.activemq:activemq-web-consoleAffected
  • >=6.0.0 <6.2.7
Fixed in
  • 6.2.7

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade Apache ActiveMQ and the Web Console to version 5.19.8 or 6.2.7 to remediate this vulnerability. No additional mitigations are specified or required beyond applying the official fix.

Description

Apache ActiveMQ and its Web Console contain a cross-site scripting (XSS) vulnerability in the browse page of the web console. This flaw allows an authenticated message producer to craft a JMS message ID containing malicious HTML or JavaScript. When an administrator views the queue in the Web Console, the malicious script executes in their browser. Versions before 5.19.8 and from 6.0.0 before 6.2.7 are affected. Upgrading to versions 5.19.8 or 6.2.7 resolves the issue.

References

Community reviews

Loading reviews…