Skip to main content
VulnerabilityPublished Updated

CVE-2026-41043: Org.apache.activemq:apache activemq: Apache ActiveMQ Vulnerable to Cross-site Scripting

Affects org.apache.activemq:apache-activemqSource GCVE Database

0
Authoritative record:CVE-2026-41043· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 5.19.6 when convenient.

Data as of 27 Oct 2026, 01:29 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.19.6, 6.2.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-broker to 5.19.6; org.apache.activemq:apache-activemq and org.apache.activemq:activemq-all and org.apache.activemq:activemq-broker to 6.2.5.

Affected software

ProductAffectedFixed in
Mavenorg.apache.activemq:apache-activemqAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:activemq-allAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:activemq-brokerAffected
  • <5.19.6
Fixed in
  • 5.19.6
Mavenorg.apache.activemq:apache-activemqAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Mavenorg.apache.activemq:activemq-allAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5
Mavenorg.apache.activemq:activemq-brokerAffected
  • >=6.0.0 <6.2.5
Fixed in
  • 6.2.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache ActiveMQ to version 5.19.6 or 6.2.5, where this vulnerability is fixed. Since a patch is available, applying the official update is the recommended mitigation.

Description

Apache ActiveMQ versions before 5.19.6 and from 6.0.0 before 6.2.5 contain a cross-site scripting (XSS) vulnerability in the web console. An authenticated attacker can inject malicious HTML content by overriding the content type and injecting HTML into a JMS selector field, potentially leading to script execution in the user's browser. The issue is fixed in versions 5.19.6 and 6.2.5.

References

Community reviews

Loading reviews…