CVE-2026-40563: Org.apache.atlas:apache atlas: Apache Atlas has a Code Injection Vulnerability
Affects org.apache.atlas:apache-atlasSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade to 2.5.0 soon.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 2.5.0
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.atlas:apache-atlas to 2.5.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.atlas:apache-atlas | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
### Description: Improper Control of Generation of Code ('Code Injection') vulnerability in Apache Atlas. Apache Atlas exposes a DSL search endpoint that accepts user-supplied query strings. Attacker can alter Gremlin traversal logic within grammar-allowed characters to access unintended data. ### Affected Version: This issue affects Apache Atlas: from 0.8-incubating through 2.4.0. For affected versions >= 2.0.0, the vulnerability is only exploitable when Atlas is deployed with below non-default configuration. `atlas.dsl.executor.traversal=false` ### Mitigation: Users are recommended to upgrade to version 2.5.0, which fixes the issue.