Org.apache.cxf:cxf core: Apache CXF is vulnerable to DoS attacks as entire files are read into memory and logged
Affects org.apache.cxf:cxf-coreSource GCVE Database
Not known to be exploited · CVSS 5.6 Medium : upgrade to 3.5.11 when convenient.
Data as of 4 Nov 2026, 18:15 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 5.6 |
|---|
- Patch
- Available – fixed in 3.5.11, 3.6.6, 4.0.7 +1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.cxf:cxf-core | Affected
| Fixed in
|
| Mavenorg.apache.cxf:cxf-core | Affected
| Fixed in
|
| Mavenorg.apache.cxf:cxf-core | Affected
| Fixed in
|
| Mavenorg.apache.cxf:cxf-core | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache CXF versions 3.5.11, 3.6.6, 4.0.7, or 4.1.1 where this issue is fixed. Applying these official fixes will prevent the denial of service condition and the unencrypted logging of sensitive temporary files.
Description
Apache CXF versions prior to 3.5.11, between 3.6.0 and 3.6.6, between 4.0.0 and 4.0.7, and between 4.1.0 and 4.1.1 have a vulnerability where large temporary files are fully read into memory and logged unencrypted. This can lead to denial of service via out of memory exceptions and exposure of sensitive data in logs. Fixed versions are 3.5.11, 3.6.6, 4.0.7, and 4.1.1.
References
- nvd.nist.gov/vuln/detail/CVE-2025-48795 (opens in a new tab)
- github.com/apache/cxf/pull/2258 (opens in a new tab)
- github.com/apache/cxf/commit/1c1d687f8e295f433a3592a3bc0b0a63c432bfde (opens in a new tab)
- github.com/apache/cxf (opens in a new tab)
- lists.apache.org/thread/vo5qv02mvv5plmb6z2xf1ktjmrpv3jmn (opens in a new tab)
- openwall.com/lists/oss-security/2025/07/15/3 (opens in a new tab)