CVE-2025-61735: Org.apache.kylin:kylin: Apache Kylin Server-Side Request Forgery (SSRF) Vulnerability
Affects org.apache.kylin:kylinSource GCVE Database
Not known to be exploited · CVSS 7.3 High : upgrade to 5.0.3 soon.
Data as of 4 Nov 2026, 18:18 UTC
- Patch
- Available – fixed in 5.0.3
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.apache.kylin:kylin and org.apache.kylin:kylin-common-server and org.apache.kylin:kylin-common-service and org.apache.kylin:kylin-core-common and org.apache.kylin:kylin-core-metadata and org.apache.kylin:kylin-ops-server and org.apache.kylin:kylin-server to 5.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.kylin:kylin | Affected
| Fixed in
|
| Mavenorg.apache.kylin:kylin-common-server | Affected
| Fixed in
|
| Mavenorg.apache.kylin:kylin-common-service | Affected
| Fixed in
|
| Mavenorg.apache.kylin:kylin-core-common | Affected
| Fixed in
|
| Mavenorg.apache.kylin:kylin-core-metadata | Affected
| Fixed in
|
| Mavenorg.apache.kylin:kylin-ops-server | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Apache Kylin to version 5.0.3, which contains the official fix for this SSRF vulnerability. Ensure that system and project administrative access controls are properly secured to reduce risk.
Description
Apache Kylin versions from 4.0.0 up to 5.0.2 contain a Server-Side Request Forgery (SSRF) vulnerability. This flaw allows an attacker to induce the server to make unintended requests, potentially leading to information disclosure and impact on confidentiality, integrity, and availability. The vulnerability is fixed in version 5.0.3. Users are advised to upgrade to this version to mitigate the risk.
References
- nvd.nist.gov/vuln/detail/CVE-2025-61735 (opens in a new tab)
- github.com/apache/kylin/pull/2332 (opens in a new tab)
- github.com/apache/kylin/commit/22eb8fd5dfdeffa3fc57bae6d5c82a019eece662 (opens in a new tab)
- github.com/apache/kylin (opens in a new tab)
- issues.apache.org/jira/browse/KYLIN-6082 (opens in a new tab)
- lists.apache.org/thread/yscobmx869zvprsykb94r24jtmb58ckh (opens in a new tab)
- openwall.com/lists/oss-security/2025/09/30/9 (opens in a new tab)