Apache Kylin versions from 4.0.0 up to 5.0.2 contain a Server-Side Request Forgery (SSRF) vulnerability. This flaw allows an attacker to induce the server to make unintended requests, potentially leading to information disclosure and impact on confidentiality, integrity, and availability. The vulnerability is fixed in version 5.0.3. Users are advised to upgrade to this version to mitigate the risk.