Skip to main content
CVE-2026-55276VulnerabilityPublished Updated

Org.apache.tomcat.embed:tomcat embed core: Apache Tomcat has an Always-Incorrect Control Flow Implementation

Affects org.apache.tomcat.embed:tomcat-embed-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-55276· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 11.0.23 as a priority.

Data as of 4 Nov 2026, 17:14 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.23, 10.1.56, 9.0.119
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-util-scan to 11.0.23; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-util-scan to 10.1.56; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-util-scan to 9.0.119.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.119
Fixed in
  • 9.0.119
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=8.5.0 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat:tomcatAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat:tomcatAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users are strongly recommended to upgrade to Apache Tomcat versions 8.5.101, 9.0.119, 10.1.56, or 11.0.23 to remediate this vulnerability. Applying these official fixes will resolve the incorrect control flow implementation and ensure accurate logging of authorization constraints.

Description

Apache Tomcat versions from 8.5.0 through 8.5.100, 9.0.0.M1 through 9.0.118, 10.1.0-M1 through 10.1.55, and 11.0.0-M1 through 11.0.22 contain an Always-Incorrect Control Flow Implementation vulnerability. This flaw causes special roles and empty authorization constraints to be omitted when the effective web.xml configuration is logged. The issue is fixed in versions 8.5.101, 9.0.119, 10.1.56, and 11.0.23. The vulnerability has a CVSS score of 9.1, indicating critical severity with high confidentiality and integrity impact but no availability impact.

References

Community reviews

Loading reviews…