Skip to main content
CVE-2026-53404VulnerabilityPublished Updated

Org.apache.tomcat.embed:tomcat embed core: Apache Tomcat's rewrite valve has an Always-Incorrect Control Flow

Affects org.apache.tomcat.embed:tomcat-embed-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2026-53404· High 7.3

Not known to be exploited · CVSS 7.3 High : upgrade to 11.0.23 soon.

Data as of 4 Nov 2026, 17:14 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.23, 10.1.56, 9.0.119
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 11.0.23; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 10.1.56; org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-catalina to 9.0.119.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.0.M1 <9.0.119
Fixed in
  • 9.0.119
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=8.5.0 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat:tomcatAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat:tomcatAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat versions to 11.0.23, 10.1.56, or 9.0.119 where the vulnerability is fixed. Since a patch is available and official fixes have been released, applying these updates is the recommended mitigation.

Description

Apache Tomcat's rewrite valve contains an Always-Incorrect Control Flow Implementation vulnerability that causes the skipping of subsequent non-OR conditions if the first condition in an OR chain matches. This affects multiple versions of Apache Tomcat from 8.5.0 through 11.0.22. The issue is fixed in versions 11.0.23, 10.1.56, and 9.0.119. The vulnerability has a high severity with a CVSS score of 7.3.

References

Community reviews

Loading reviews…