Skip to main content
VulnerabilityPublished Updated

CVE-2026-55955: Org.apache.tomcat:tomcat: Apache Tomcat has an Improper Authentication vulnerability

Affects org.apache.tomcat:tomcatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-55955· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium : upgrade to 11.0.23 when convenient.

Data as of 4 Nov 2026, 17:15 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.23, 10.1.56, 9.0.119
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-tribes to 11.0.23; org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-tribes to 10.1.56; org.apache.tomcat:tomcat and org.apache.tomcat:tomcat-tribes to 9.0.119.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcatAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat:tomcatAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56
Mavenorg.apache.tomcat:tomcatAffected
  • >=9.0.13 <9.0.119
Fixed in
  • 9.0.119
Mavenorg.apache.tomcat:tomcatAffected
  • >=8.5.38 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat:tomcatAffected
  • >=7.0.100 <=7.0.109
Fixed in–
Mavenorg.apache.tomcat:tomcat-tribesAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade affected Apache Tomcat versions to 11.0.23, 10.1.56, or 9.0.119 where the vulnerability is fixed. Applying these official patches fully mitigates the issue.

Description

Apache Tomcat contains an improper authentication vulnerability (CVE-2026-55955) affecting multiple versions from 7.0.100 through 11.0.22. This flaw allows a replay attack against the EncryptionInterceptor in the cluster component. The issue is fixed in versions 11.0.23, 10.1.56, and 9.0.119.

References

Community reviews

Loading reviews…