Skip to main content
VulnerabilityPublished Updated

CVE-2026-50229: Org.apache.tomcat:tomcat: Apache Tomcat has a Cross-site Scripting vulnerability

Affects org.apache.tomcat:tomcatSource GCVE Database

0
Compare
Authoritative record:CVE-2026-50229· Medium 6.1

Not known to be exploited · public detection template (Nuclei) · CVSS 6.1 Medium : upgrade to 11.0.23 when convenient.

Data as of 4 Nov 2026, 17:15 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.23, 10.1.56, 9.0.119
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jun 2026

  2. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: evidence found.

    3 exposed hosts found; no attack traffic recorded

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), OffSeq Mirage (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.tomcat:tomcat to 11.0.23; org.apache.tomcat:tomcat to 10.1.56; org.apache.tomcat:tomcat to 9.0.119.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcatAffected
  • >=11.0.0-M1 <11.0.23
Fixed in
  • 11.0.23
Mavenorg.apache.tomcat:tomcatAffected
  • >=10.1.0-M1 <10.1.56
Fixed in
  • 10.1.56
Mavenorg.apache.tomcat:tomcatAffected
  • >=9.0.0.M1 <9.0.119
Fixed in
  • 9.0.119
Mavenorg.apache.tomcat:tomcatAffected
  • >=8.5.0 <=8.5.100
Fixed in–
Mavenorg.apache.tomcat:tomcatAffected
  • <=7.0.109
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users are advised to upgrade to Apache Tomcat versions 11.0.23, 10.1.56, or 9.0.119 or later, where this vulnerability has been fixed. Applying these official fixes will remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

Apache Tomcat contains a cross-site scripting (XSS) vulnerability in the number guess example that affects multiple versions across the 7.x, 8.5.x, 9.x, 10.1.x, and 11.x branches. This vulnerability allows improper neutralization of script-related HTML tags, potentially enabling script injection. Fixed versions are available in Apache Tomcat 11.0.23, 10.1.56, and 9.0.119.

References

Community reviews

Loading reviews…