Skip to main content
VulnerabilityPublished Updated

CVE-2025-31650: Org.apache.tomcat:tomcat coyote: Apache Tomcat Denial of Service via invalid HTTP priority header

Affects org.apache.tomcat:tomcat-coyoteSource GCVE Database

0
Compare
Authoritative record:CVE-2025-31650· High 7.5

Public exploit available (Exploit-DB) · CVSS 7.5 High : upgrade to 9.0.104 as a priority.

Data as of 29 Oct 2026, 22:52 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.17.5
Patch
Available – fixed in 9.0.104, 10.1.40, 11.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 28 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  4. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by Apache Software Foundation

    , 28 days before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. First Exploit-DB entry (opens in a new tab)

    Apache Tomcat 10.1.39 - Denial of Service (DoS)

    , 38 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core to 9.0.104; org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core to 10.1.40; org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core to 11.0.6.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=9.0.76 <9.0.104
Fixed in
  • 9.0.104
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=10.1.10 <10.1.40
Fixed in
  • 10.1.40
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=11.0.0-M2 <11.0.6
Fixed in
  • 11.0.6
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.76 <9.0.104
Fixed in
  • 9.0.104
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.10 <10.1.40
Fixed in
  • 10.1.40
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M2 <11.0.6
Fixed in
  • 11.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Input Validation vulnerability in Apache Tomcat. Incorrect error handling for some invalid HTTP priority headers resulted in incomplete clean-up of the failed request which created a memory leak. A large number of such requests could trigger an OutOfMemoryException resulting in a denial of service. This issue affects Apache Tomcat: from 9.0.76 through 9.0.102, from 10.1.10 through 10.1.39, from 11.0.0-M2 through 11.0.5. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.90 though 8.5.100. Users are recommended to upgrade to version 9.0.104, 10.1.40 or 11.0.6 which fix the issue.

References

Community reviews

Loading reviews…