Skip to main content
VulnerabilityPublished Updated

CVE-2026-24734: Org.apache.tomcat:tomcat coyote: Apache Tomcat has an Improper Input Validation vulnerability

Affects org.apache.tomcat:tomcat-coyoteSource GCVE Database

0
Compare
Authoritative record:CVE-2026-24734· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade to 11.0.18 soon.

Data as of 4 Nov 2026, 04:13 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 11.0.18, 10.1.52, 9.0.115
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote-ffm to 11.0.18; org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote-ffm to 10.1.52; org.apache.tomcat:tomcat-coyote and org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat-coyote-ffm to 9.0.115.

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=11.0.0-M1 <11.0.18
Fixed in
  • 11.0.18
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=10.1.0-M7 <10.1.52
Fixed in
  • 10.1.52
Mavenorg.apache.tomcat:tomcat-coyoteAffected
  • >=9.0.83 <9.0.115
Fixed in
  • 9.0.115
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=11.0.0-M1 <11.0.18
Fixed in
  • 11.0.18
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=10.1.0-M7 <10.1.52
Fixed in
  • 10.1.52
Mavenorg.apache.tomcat.embed:tomcat-embed-coreAffected
  • >=9.0.83 <9.0.115
Fixed in
  • 9.0.115

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

References

Community reviews

Loading reviews…