Skip to main content
VulnerabilityPublished Updated

CVE-2026-24734: Apache Tomcat Native · Improper Input Validation

Affects Apache Tomcat NativeSource CVE Database V5

0

Not known to be exploited · CVSS 7.4 High · fixed in 1.3.5 : patch Apache Tomcat Native soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.3.5
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache Tomcat NativeAffected
  • >=1.1.23 <=1.1.34
  • >=1.2.0 <=1.2.39
  • >=1.3.0 <=1.3.4
  • >=2.0.0 <=2.0.11
Fixed in–
Apache Software FoundationApache TomcatAffected
  • >=11.0.0-M1 <=11.0.17
  • >=10.1.0-M7 <=10.1.51
  • >=9.0.83 <=9.0.114
Fixed in–

AI-suggested

A fix is available. Users should upgrade Apache Tomcat Native to version 1.3.5 or later, or 2.0.12 or later, and Apache Tomcat to version 11.0.18 or later, 10.1.52 or later, or 9.0.115 or later. Red Hat has released updated JBoss Web Server packages incorporating these fixes. Applying these updates will remediate the vulnerability. No other specific mitigations are indicated by the vendor advisories.

Description

Improper Input Validation vulnerability in Apache Tomcat Native, Apache Tomcat. When using an OCSP responder, Tomcat Native (and Tomcat's FFM port of the Tomcat Native code) did not complete verification or freshness checks on the OCSP response which could allow certificate revocation to be bypassed. This issue affects Apache Tomcat Native:  from 1.3.0 through 1.3.4, from 2.0.0 through 2.0.11; Apache Tomcat: from 11.0.0-M1 through 11.0.17, from 10.1.0-M7 through 10.1.51, from 9.0.83 through 9.0.114. The following versions were EOL at the time the CVE was created but are known to be affected: from 1.1.23 through 1.1.34, from 1.2.0 through 1.2.39. Older EOL versions are not affected. Apache Tomcat Native users are recommended to upgrade to versions 1.3.5 or later or 2.0.12 or later, which fix the issue. Apache Tomcat users are recommended to upgrade to versions 11.0.18 or later, 10.1.52 or later or 9.0.115 or later which fix the issue.

References

Community reviews

Loading reviews…