CVE-2026-40010: Org.apache.wicket:wicket auth roles: Apache Wicket has a Session Fixation issue
Affects org.apache.wicket:wicket-auth-rolesSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 10.9.0 as a priority.
Data as of 27 Oct 2026, 00:57 UTC
- Patch
- Available – fixed in 10.9.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.apache.wicket:wicket-auth-roles to 10.9.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.apache.wicket:wicket-auth-roles | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-auth-roles | Affected
| Fixed in– |
| Mavenorg.apache.wicket:wicket-auth-roles | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Apache Wicket version 10.9.0 or later, where this session fixation vulnerability is fixed. No other mitigation or temporary workaround is indicated by the vendor advisory.
Description
Apache Wicket versions from 8.0.0 through 8.17.0, 9.0.0 through 9.22.0, and 10.0.0 through 10.8.0 are affected by a session fixation vulnerability (CVE-2026-40010). The issue arises from missing invocation of the Servlet HTTP request method changeSessionId after session binding, which can allow an attacker to fixate a user's session ID. This vulnerability is fixed in version 10.9.0.