Skip to main content
CVE-2025-59475VulnerabilityPublished Updated

Org.jenkins ci.main:jenkins core: Jenkins is missing a permission check in the authenticated users' profile menu

Affects org.jenkins-ci.main:jenkins-coreSource GCVE Database

0
Compare
Authoritative record:CVE-2025-59475· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade to 2.516.3 when convenient.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.14.3
Patch
Available – fixed in 2.516.3, 2.528
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.jenkins-ci.main:jenkins-core to 2.516.3; org.jenkins-ci.main:jenkins-core to 2.528.

Affected software

ProductAffectedFixed in
Mavenorg.jenkins-ci.main:jenkins-coreAffected
  • <2.516.3
Fixed in
  • 2.516.3
Mavenorg.jenkins-ci.main:jenkins-coreAffected
  • >=2.517 <2.528
Fixed in
  • 2.528

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Jenkins to version 2.516.3 or later in the LTS line, or version 2.528 or later in the mainline, where the permission check for the authenticated user profile dropdown menu is enforced. Since a patch is available and fixed versions are known, applying these updates fully mitigates the vulnerability.

Description

Jenkins versions 2.527 and earlier, including LTS 2.516.2 and earlier, have a vulnerability where the authenticated user profile dropdown menu does not perform a permission check. This flaw allows attackers without Overall/Read permission to gather limited information about the Jenkins configuration, such as the presence of certain plugins. The issue is fixed in Jenkins versions 2.516.3 and 2.528, which require Overall/Read permission to access these menu items.

References

Community reviews

Loading reviews…