CVE-2026-93363: @payloadcms/storage-vercel-blob has access control bypass of uploads in Vercel Storage adapter
Affects @payloadcms/storage-vercel-blobSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.90.0 when convenient.
Data as of 4 Nov 2026, 18:30 UTC
- Patch
- Available – fixed in 3.90.0, 4.0.0-canary.34
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade @payloadcms/storage-vercel-blob to 3.90.0; @payloadcms/storage-vercel-blob to 4.0.0-canary.34.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@payloadcms/storage-vercel-blob | Affected
| Fixed in
|
| npm@payloadcms/storage-vercel-blob | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade the @payloadcms/storage-vercel-blob package to version 3.90.0 or later, or to 4.0.0-canary.34 or later, where the vulnerability is fixed. Until an upgrade is possible, disable client uploads or configure the upload route's access control to enforce the associated collection’s permissions to prevent unauthorized upload access.
Description
A vulnerability in the @payloadcms/storage-vercel-blob package allows authenticated users to bypass access control for client uploads in certain versions. This occurs because client upload access does not consistently enforce the collection-level access permissions. The issue affects versions >=3.25.0 <3.90.0 and >=4.0.0-canary.0 <4.0.0-canary.34. A fix is available in versions 3.90.0 and 4.0.0-canary.34, which require authentication and proper collection-level access for uploads.
References
- github.com/payloadcms/payload/security/advisories/GHSA-mc8m-rr6c-r5qr (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-93363 (opens in a new tab)
- github.com/payloadcms/payload/commit/47abe9bb5c444330dbfaa9a5bc2033337932270b (opens in a new tab)
- github.com/payloadcms/payload (opens in a new tab)
- github.com/payloadcms/payload/releases/tag/v3.90.0 (opens in a new tab)
- vulncheck.com/advisories/payload-cms-storage-vercel-blob-adapter-improper-access-control-on-upload-route (opens in a new tab)