Org.jenkins ci.plugins:applitools eyes: Jenkins Applitools Eyes Plugin vulnerable to XSS through its Build page
Affects org.jenkins-ci.plugins:applitools-eyesSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 1.16.6 when convenient.
Data as of 4 Nov 2026, 17:16 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 5.4 |
|---|
- Patch
- Available – fixed in 1.16.6
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 9 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade org.jenkins-ci.plugins:applitools-eyes to 1.16.6.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.jenkins-ci.plugins:applitools-eyes | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Jenkins Applitools Eyes Plugin 1.16.5 and earlier does not escape the Applitools URL on the build page. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission. Applitools Eyes Plugin 1.16.6 rejects Applitools URLs that contain HTML metacharacters.