CVE-2026-41573: Org.openidentityplatform.openam:openam core rest: OpenAM has LDAP Injection via `_queryId` Parameter
Affects org.openidentityplatform.openam:openam-core-restSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 7.1 High : upgrade to 16.1.1 soon.
Data as of 28 Oct 2026, 17:11 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.openidentityplatform.openam:openam-core-rest to 16.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.openidentityplatform.openam:openam-core-rest | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenAM version 16.1.1 that fixes this LDAP injection vulnerability by properly escaping the `_queryId` parameter. Users should upgrade to version 16.1.1 or later to remediate this issue. Since the vulnerability requires authentication, ensure that access to the affected endpoints is properly controlled. No additional mitigations are specified by the vendor advisory.
Description
OpenAM, an open-source identity and access management platform, has an LDAP injection vulnerability in its REST API. The flaw exists in the `_queryId` HTTP query parameter used in user and group query endpoints, where input is not properly escaped before being incorporated into LDAP filter strings. This allows authenticated attackers to inject LDAP metacharacters, potentially enabling user enumeration and blind LDAP injection attacks. The vulnerability affects OpenAM versions prior to 16.1.1 and has a high severity rating with a CVSS score of 8.7. A fix is available in version 16.1.1.
References
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-2vg8-q4c2-5cw3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-41573 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/commit/d3d86c951a4c3c353719b761ea0b4be80f9dd241 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1 (opens in a new tab)
- github.com/advisories/GHSA-8984-9gww-h52x (opens in a new tab)