Skip to main content
CVE-2026-45049VulnerabilityPublished Updated

Org.openidentityplatform.openam:openam federation: OpenAM Unauthenticated Session Hijacking via Information Exposure

Affects org.openidentityplatform.openam:openam-federationSource GCVE Database

0

Not known to be exploited · CVSS 8.3 High : upgrade to 16.1.1 soon.

Data as of 28 Oct 2026, 16:44 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 16.1.1
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.openidentityplatform.openam:openam-federation to 16.1.1.

Affected software

ProductAffectedFixed in
Mavenorg.openidentityplatform.openam:openam-federationAffected
  • <16.1.1
Fixed in
  • 16.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in OpenAM Community Edition version 16.1.1. Users should update to this version to remediate the vulnerability. No additional mitigations are specified or required if the patch is applied.

Description

OpenAM Community Edition through version 16.0.6 contains an information exposure vulnerability in its Cross-Domain Single Sign-On (CDSSO) servlet. This flaw allows a logged-in user's raw session token to be sent via POST to an attacker-controlled URL if the user is induced to visit a crafted link. The vulnerability requires user interaction and a non-default configuration where CDSSO is enabled. It was fixed in version 16.1.1.

References

Community reviews

Loading reviews…