Org.openidentityplatform.openam:openam oauth2: OpenAM Arbitrary OAuth Token Minting via Push Registration
Affects org.openidentityplatform.openam:openam-oauth2Source GCVE Database
Not known to be exploited · CVSS 7.6 High : upgrade to 16.1.1 soon.
Data as of 28 Oct 2026, 17:11 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 35% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Mavenorg.openidentityplatform.openam:openam-oauth2 | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenAM Community Edition version 16.1.1. Users should update to this version or later to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.
Description
A vulnerability in OpenAM Community Edition through version 16.0.6 allows an attacker to forge OAuth2 bearer tokens and OIDC ID tokens with arbitrary attributes by exploiting an authorization bypass through a user-controlled key. The flaw exists in the OAuth2 token-read path, which improperly accepts attacker-controlled tokens from the shared Core Token Store without proper integrity checks. This vulnerability requires the attacker to place malicious JSON data into the token store, which can be triggered via a low-privileged user in a Push Notification-enabled realm. The issue is patched in version 16.1.1.
References
- github.com/OpenIdentityPlatform/OpenAM/security/advisories/GHSA-cj8f-2fhf-826r (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-46498 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/commit/e047b01f24ce5006dbd62b3084b17df2d7835763 (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM (opens in a new tab)
- github.com/OpenIdentityPlatform/OpenAM/releases/tag/16.1.1 (opens in a new tab)