Skip to main content
CVE-2026-44203VulnerabilityPublished Updated

Org.openidentityplatform.openam:openam oauth2: OpenAM has pre-auth Reflected XSS in OAuth2 / OIDC

Affects org.openidentityplatform.openam:openam-oauth2Source GCVE Database

0
Authoritative record:CVE-2026-44203· High 8.3

Not known to be exploited · CVSS 8.3 High : upgrade to 16.1.1 soon.

Data as of 28 Oct 2026, 17:11 UTC

CVSS 4.0 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.openidentityplatform.openam:openam-oauth2 to 16.1.1.

Affected software

ProductAffectedFixed in
Mavenorg.openidentityplatform.openam:openam-oauth2Affected
  • >=13.0.0 <16.1.1
Fixed in
  • 16.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and users should upgrade to OpenAM version 16.1.1 or later to remediate this vulnerability. No additional mitigations are specified by the vendor advisory.

Description

A reflected cross-site scripting (XSS) vulnerability exists in the OAuth 2.0 / OpenID Connect authorization endpoint of OpenAM when using the form_post response mode. The vulnerability arises because certain user-supplied parameters are not properly sanitized before being included in the HTML response. This flaw affects OpenAM versions from 13.0.0 up to but not including 16.1.1. A fix is available in version 16.1.1.

References

Community reviews

Loading reviews…