Skip to main content
VulnerabilityPublished

CVE-2026-118254: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 8.6 High : upgrade to 13.0.0-beta.2 soon.

Data as of 28 Oct 2026, 18:44 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.0.0-beta.2, 3.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts to 13.0.0-beta.2; grid-lite and grid-pro to 3.2.0; highcharts/highcharts to 13.0.0-beta.2 or 3.2.0.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • <13.0.0-beta.2
Fixed in
  • 13.0.0-beta.2
@highchartsgrid-liteAffected
  • >=2.0.0 <3.2.0
Fixed in
  • 3.2.0
@highchartsgrid-proAffected
  • >=2.0.0 <3.2.0
Fixed in
  • 3.2.0
GitHubhighcharts/highchartspkg:github/highcharts/highchartsOther threatsAffected
  • <13.0.0-beta.2
  • >=2.0.0 <3.2.0
Fixed in
  • 13.0.0-beta.2
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Highcharts JS to version 3.2.0 or later, including 13.0.0-beta.2 and beyond, where this vulnerability is fixed. No other mitigations are indicated by the vendor advisory. Applying the official fix fully resolves the issue.

Description

Highcharts JS versions from 2.0.0 up to but not including 3.2.0 contain a cross-site scripting (XSS) vulnerability in the Grid pagination feature. The vulnerability arises because pagination language strings are written into the DOM as markup rather than text, allowing an attacker controlling the Grid language configuration to inject elements with event handlers. This leads to script execution in the context of the hosting page without requiring user interaction. The issue is fixed in version 3.2.0 and later.

References

Community reviews

Loading reviews…