Skip to main content
VulnerabilityPublished

CVE-2026-118251: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High · fixed in 13.1.1 : patch highcharts soon.

Data as of 28 Oct 2026, 18:44 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.1.1, 12.6.1, 11.4.9
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts and highcharts/highcharts to 13.1.1, 12.6.1 or 11.4.9.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • >=13.0.0 <13.1.1
Fixed in
  • 13.1.1
highchartshighchartsAffected
  • >=12.0.0 <12.6.1
Fixed in
  • 12.6.1
highchartshighchartsAffected
  • <11.4.9
Fixed in
  • 11.4.9
npmhighcharts/highchartspkg:npm/highcharts/highchartsOther threatsAffected
  • <11.4.9
  • >=12.0.0 <12.6.1
  • >=13.0.0 <13.1.1
Fixed in
  • 11.4.9
  • 12.6.1
  • 13.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Highcharts to version 11.4.9, 12.6.1, or 13.1.1 or later, where this vulnerability is fixed. No other mitigation is indicated by the vendor advisory. Users should ensure they do not use vulnerable versions and avoid using untrusted chart configurations.

Description

Highcharts JS versions prior to 11.4.9, 12.6.1, and 13.1.1 contain a cross-site scripting (XSS) vulnerability. The issue arises because the credits.href property is assigned directly to the window location without validating the URL scheme. An attacker controlling the chart configuration can supply a javascript: URL, which executes script in the context of the hosting page when a user clicks the credits label. This vulnerability affects Highcharts and its related packages Highcharts Stock, Maps, and Gantt. The issue is fixed in versions 11.4.9, 12.6.1, and 13.1.1.

References

Community reviews

Loading reviews…