Skip to main content
VulnerabilityPublished

CVE-2026-118244: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 7.2 High : upgrade to 13.1.0 or 12.6.1 soon.

Data as of 28 Oct 2026, 18:12 UTC

CVSS 4.0 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.1.0, 12.6.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts and highcharts/highcharts to 13.1.0 or 12.6.1.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • >=13.0.0 <13.1.0
Fixed in
  • 13.1.0
highchartshighchartsAffected
  • >=12.0.0 <12.6.1
Fixed in
  • 12.6.1
GitHubhighcharts/highchartspkg:github/highcharts/highchartsOther threatsAffected
  • >=12.0.0 <12.6.1
  • >=13.0.0 <13.1.0
Fixed in
  • 12.6.1
  • 13.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in Highcharts versions 12.6.1 and 13.1.0. Users and administrators should upgrade to these versions or later to remediate the vulnerability. Since this is a cloud service, the vendor manages remediation for hosted instances; verify with the vendor that the service is updated. No additional mitigation steps are indicated by the vendor advisory.

Description

Highcharts JS versions from 12.0.0 up to but not including 12.6.1, and from 13.0.0 up to but not including 13.1.0, are affected by a cross-site scripting (XSS) vulnerability. This occurs because Highcharts falls back to assigning raw markup to innerHTML when DOMParser fails, before applying its allow-list. In Chromium browsers, this can lead to execution of untrusted HTML event handlers during the beforeprint event when charts are redrawn. The vulnerability affects HTML-rendered titles, labels, data labels, responsive text, and related Highcharts products. The issue is fixed in versions 12.6.1 and 13.1.0.

References

Community reviews

Loading reviews…