Skip to main content
VulnerabilityPublished

CVE-2026-118253: highcharts · Cross-site Scripting

Affects highchartsSource CVE Database V5

0

Not known to be exploited · CVSS 8.4 High : upgrade to 13.0.0-beta.2 soon.

Data as of 28 Oct 2026, 18:44 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 13.0.0-beta.2, 4.2.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade highcharts to 13.0.0-beta.2; dashboards to 4.2.3; highcharts/highcharts to 13.0.0-beta.2 or 4.2.3.

Affected software

ProductAffectedFixed in
highchartshighchartsAffected
  • <13.0.0-beta.2
Fixed in
  • 13.0.0-beta.2
@highchartsdashboardsAffected
  • >=1.0.0 <4.2.3
Fixed in
  • 4.2.3
GitHubhighcharts/highchartspkg:github/highcharts/highchartsOther threatsAffected
  • <13.0.0-beta.2
  • >=1.0.0 <4.2.3
Fixed in
  • 13.0.0-beta.2
  • 4.2.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

This vulnerability is fixed in Highcharts versions 4.2.3 and 13.0.0-beta.2. Users should upgrade to one of these versions or later to remediate the issue. No additional mitigation is required if the upgrade is applied. If upgrading immediately is not possible, disabling edit mode or removing the fullscreen view option from the context menu can reduce exposure, but the vendor advisory does not specify these as official mitigations.

Description

CVE-2026-118253 is a high severity cross-site scripting (XSS) vulnerability in Highcharts JS versions from 1.0.0 up to but not including 4.2.3. The issue occurs in Highcharts Dashboards edit mode where fullscreen language labels are parsed as HTML instead of text, allowing an attacker controlling language options to inject malicious markup with event handlers. This code executes in the context of the hosting page when the fullscreen control is rendered. The vulnerability is only exploitable when edit mode is enabled and the fullscreen view option is present. The flaw is fixed in versions 4.2.3 and 13.0.0-beta.2.

References

Community reviews

Loading reviews…