CVE-2026-118252: highcharts · Cross-site Scripting
Affects highchartsSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 13.0.0-beta.2 soon.
Data as of 28 Oct 2026, 18:44 UTC
- Patch
- Available – fixed in 13.0.0-beta.2, 4.2.3
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade highcharts to 13.0.0-beta.2; dashboards to 4.2.3; highcharts/highcharts to 13.0.0-beta.2 or 4.2.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| highchartshighcharts | Affected
| Fixed in
|
| @highchartsdashboards | Affected
| Fixed in
|
npmhighcharts/highchartspkg:npm/highcharts/highchartsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Highcharts to version 4.2.3 or later, including 13.0.0-beta.2 and beyond, where this vulnerability is fixed. No additional mitigation is required once the update is applied.
Description
Highcharts JS versions from 1.0.0 up to but not including 4.2.3 contain a cross-site scripting (XSS) vulnerability in the Dashboards edit-mode sidebar. The issue arises because component language strings are parsed as HTML instead of being inserted as text, allowing an attacker who controls the Dashboards language configuration to inject malicious markup with event handlers. This code executes in the context of the hosting page when the edit-mode sidebar is opened and the affected labels render. The vulnerability is fixed in version 4.2.3.