Skip to main content
CVE-2026-40976VulnerabilityPublished Updated

Org.springframework.boot:spring boot: Spring Boot's default security filter chain has no authorization rule with

Affects org.springframework.boot:spring-bootSource GCVE Database

0
Authoritative record:CVE-2026-40976· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical : upgrade to 4.0.6 as a priority.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.0.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.springframework.boot:spring-boot to 4.0.6.

Affected software

ProductAffectedFixed in
Mavenorg.springframework.boot:spring-bootAffected
  • >=4.0.0 <4.0.6
Fixed in
  • 4.0.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

In certain circumstances, Spring Boot's default web security is ineffective allowing unauthorized access to all endpoints. For an application to be vulnerable, it must: be a servlet-based web application; have no Spring Security configuration of its own and rely on the default web security filter chain; depend on spring-boot-actuator-autoconfigure; not depend on spring-boot-health. If any of the above does not apply, the application is not vulnerable. Affected: Spring Boot 4.0.0–4.0.5; upgrade to 4.0.6 or later per vendor advisory.

References

Community reviews

Loading reviews…